Ste, a maintainer of one of the biggest iPhone repro’s posted this on his page:

Alert – Please Read – Very Important – Pass This On

The release of the 1.1.3 firmware has caused a ton of headaches for developers and package maintainers. Many packages store media and preferences under /var/root/Media and /var/root/Library. With the release of 1.1.3, most packages will now need to store that stuff under /var/mobile/Media and /var/mobile/Library.

For developers, they have to write their apps to be firmware version aware, so that they can read/write from the correct location, depending on what firmware they are running on. For packagers, we have to install/uninstall that stuff from the right place, depending on the firmware. It’s a nightmare.

Nullriver has released the full 3.0 version – no beta any more – of This release allows packagers to install the stuff mentioned above into ~/Media and ~/Library and will put it in the right place, based on the firmware of the device.

This version of also provides packagers with the ability to check how much free space is available, before installing, so that we don’t fill up the root partition any more. It also adds features that will help in migrating applications out of /Applications to other locations. There is more – this release is really chock full of stuff to make life easier for all of us.

It is imperative that you upgrade to 3.0 as soon as possible. By that, I mean NOW. Right now, today. I am going to start releasing package updates today that will rely on the new features. They will not install correctly on older releases of If you run into any trouble and find you need to manually download and install, get it from here ( ), which always points to the latest version. Other repositories will start using these new features shortly, too, so it really is in your best interest to upgrade right this minute. If you do not, and you have an issue installing any of my packages, my response will be “please upgrade, try again, and only come back if you still have a problem”.

To prevent this kind of chicken-and-egg issue in the future, one new feature in this release is the ability for the package maintainer to specify a minimum version required for the package to install. Unfortunately, this time, we can’t really use it, because the older Installer.apps don’t understand that feature.

For a full listing of changes in this release of, please see the “Featured” page in your current