This application by MPH allows you to load PSP games which were supposed to work with 2.00 only on a 1.50 firmware PSP. Release notes:

Here the game loader 1.1 with support umd.
Because i have no time for the moment, the multiplayers and sleep bugs are not corrected for the moment, it will be for the next version.
The compatibility is likely to be reduced because decoding is performed in the loader and because of the memory I am limited (64ko) to decipher prx but the next version will not have this constraint.